nerdexam
CrowdStrike

CCFH-202B · Question #82

What is the purpose of the rename command in this query? event_simpleName=ProcessRollup2 [search event_simpleName=ProcessRollup2 FileName=excel.exe | rename TargetProcessId_decimal AS…

The correct answer is B. It renames a field to drive the main search in order to locate all children processes of excel.exe. You've hit your limit · resets 12:50am (America/New_York)

Event Search Query Construction

Question

What is the purpose of the rename command in this query? event_simpleName=ProcessRollup2 [search event_simpleName=ProcessRollup2 FileName=excel.exe | rename TargetProcessId_decimal AS ParentProcessId_decimal | fields aid ParentProcessId_decimal] | stats count by FileName CommandLine

Options

  • AIt runs a sub-search to locate all detections where excel.exe was blocked
  • BIt renames a field to drive the main search in order to locate all children processes of excel.exe
  • CIt joins all combinations of parent / children processes involving excel.exe
  • DIt renames a field to drive the main search in order to locate all parent processes of excel.exe

How the community answered

(51 responses)
  • A
    4% (2)
  • B
    73% (37)
  • C
    8% (4)
  • D
    16% (8)

Explanation

You've hit your limit · resets 12:50am (America/New_York)

Topics

#SPL rename command#sub-search#parent-child processes#process lineage

Community Discussion

No community discussion yet for this question.

Full CCFH-202B Practice